UpSlide relies on automated procedures to keep templates and the add-in up to date via its auto-update system. These processes may occasionally be flagged and blocked by Microsoft Defender, which can interfere with the tool's proper functioning.
Issues may not appear immediately if Microsoft Defender blocks UpSlide's update processes. Typically, problems begin to surface after a few system restarts. Reinstalling UpSlide may temporarily resolve the issue, but it will recur unless the root cause is addressed.
Symptoms
The symptoms of this issue are error messages when launching an Office application. For example, you may find that you’re unable to use UpSlide in Excel but have no trouble in PowerPoint.
The error messages can be the following:
- “An add-in could not be found or could not be loaded.”
- “A part of UpSlide customization needs to be re-generated.”
- “The method or operation is not implemented.”
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Root cause
UpSlide’s update processes require running executable content in the Office environment. Microsoft Defender Advanced Threat Protection (ATP) blocks this executable content, preventing UpSlide from updating to newer versions and potentially corrupting the current installation. The following Surface Attack rules cause the issues:
- Block Office applications from creating executable content.
- Block Office applications from creating child processes.
Workaround
If UpSlide is not loading properly, you can follow these steps to retrieve a working version. Start by opening C:\ProgramData\UpSlide in the File Explorer.
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If there is a folder called NewBinaries, start by checking that the folder is not empty. Then:
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If there is NO folder called NewBinaries or it is empty:
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Solution
To prevent Microsoft Defender from interfering with UpSlide’s update process, the rules mentioned in the Root cause section must be disabled. They have to be setup on UpSlide’s installation folder, C:\ProgramData\UpSlide.
If your company has set a custom location for UpSlide’s installation folder, you must identify it before going forward with the steps below.
Set the exclusion
Open the Microsoft Endpoint Manager admin centre and go to Devices > Configuration profiles > Create a profile.

Within the Create a profile window, select:
- Windows 10 and later
- Templates
- Device restrictions

On the Microsoft Defender Antivirus tab, add exclusions for the rules above either globally or to the installation folder (default folder is C:\ProgramData\UpSlide)
- Block Office applications from creating executable content.
- Block Office applications from creating child processes.
Checking that the exclusion is applied
C:\ProgramData\UpSlide on the Windows Security > Virus & Threat Protection exclusion list.